Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
  • SoapClient and 401 unauthorized in older PHP-releases

    Using SoapClient and Basic Auth, with wrong credentials is not always handled as a catchable error. This is a bug, that was first seen in september 2006, and still not fixed as it seems. In newer PHP's this is proabably auto-cured, as warnings can be catched like normal exceptions. But since migration takes several years, NetCurl takes care of this issue via a local error handler when a soapfault occurs on the primary initialization of the SoapClient. The local errorhandler will then reinitialize the SoapClient, to investigate the problem further. The bug itself, is described here but there's also a local fix located in the tracker here:
    Jira
    serverTornevall Networks
    columnskey,summary,type,created,updated,due,assignee,reporter,priority,status,resolution
    serverIdef1f2374-e58a-319f-9d38-10348dbac859
    keyLIB-165
  • Default preconfigure $curlopt is not in use in v6.0

    No Format
    nopaneltrue
             * $curlopt will return in 6.1 but in WrapperConfig with a proper setup instead.
             * 
             * This array is not in use and seems to be unused for a long time (discovered in april 2020). The discovery
             * is based on the fact that CURLOPT_SSLVERSION was set to the value 4 (CURL_SSLVERSION_TLSv1_0) which
             * should've not worked properly with for example omnitest.resurs.com. Instead of using TLS 1.0, netcurl
             * is configuring everything on fly and is actually no longer using this part of the module. Instead,
             * CURLOPT_SSLVERSION is set to CURL_SSLVERSION_DEFAULT which means that curl tries to automatically
             * discover which TLS version that should be used. This is why the TLS connectivity "always" works.